OpenMW+Morrowind Rebirth+TamrielRebuilt





Game version: 




Found in Version: 



Title may or may not be misleading, depending on whether it's a compatibility thing or not.

Ok, so I installed OpenMW into a clean Morrowind, ran it, everything was perfect.

Installed Morrowind Rebirth into OpenMW, made sure the file structure was correct, added path to the openmw.cfg in MyGames/OpenMW as I was supposed to, and ran it, everything was perfect. No mesh errors, no load errors, nothing - all gravy baby. Ran around Seyda Neen, to Balmora on foot, and enjoyed the new city stuff and all of it. Great. I exited without saving as I always do until I get the game how I want it, where I then start my playthrough character. This lets me make a new character and load a fresh new map every single time I add a mod to make sure it's clean, and that I don't have a save issue or whatever. Anyway.

Then I installed Tamriel Rebuilt. Sigh. Added the path to openmw.cfg, as well as the BSAs as intended, so I didn't have anything weird happen when I ran it. Everything was fine, no errors or anything weird.

So got through checking in at Seyda Neen and was good to go. First thing I did was run around town, Rebirth was working without issue, no meshes or weird stuff. Until I went back to the dock I arrived in. I noticed there was a new dude there who can boat me around, all cool - but at the end of the dock where my arrival ship once was, the barrels and chest that were sitting on the front end of the ship were still there, floating in the air above the water.

I figured I'd look into it later, so I talked to the new boatmaster. Everything seemed cool, so I select travel and notice a new city, Rashan I think it was called. I traveled there (had exactly the right amount of gold, lol). Upon arrival, all seemed ok. After walking around a few seconds though, first thing I noticed, some of the trees had disjointed branches floating a few inches away from them, as if two meshes were fighting over the same spot. Bit odd, I thought. I then noticed there were no NPCs about, aside from a man in robes near where I had arrived - probably the boat guy to take me back, I didn't speak to him. Instead I tried to enter a building. Then the next, then the next...The doors just rotated in place, showing either wood behind them, or nothing (which allowed me to walk into the building and appreciate the backface culling in there).

At this point I just exited the game. Obviously something went wrong.

So to explain my installation pretty much step by step. Same way I did Rebirth of course, although there's just a tad more to TR.

-I have a Data Files folder created within my OpenMW install folder, as supposed to. To keep things organized I am going to create seperate folders for all my mods. That said, within the Data Files folder I have a Rebirth folder, containing the esps and main folders (meshes, textures, etc.). And next to that I have a Tamriel Rebuilt folder, within which I installed this mod.

-Installation order
--From this page: 
--Downloaded: Tamriel_Data(HD), Hotfix v4 High Definition, OpenMW - Patch for version 03 and 04
--Installed them into my OpenMW 0.42.0/Data Files folder, in the above order (the same as downloaded).
--From this page:
--Downloaded both the Main Files and the Music. Installed them in the same order as downloaded, just like the Data Files.
--Added the paths and the BSAs to the openmw.cfg in Documents (MyGames/Openmw). BSAs at the top as backup archives beneath the main game BSAs. File path towards the bottom where they must be, in quotes preceded by the data line, etc.
--Activated ESPs and ESMs in the OpenMW launcher
--Load Order is as follows:
Morrowind.esm (main file, in OpenMW it's a dropdown so it's always at the top)
Morrowind Rebirth 4.3 - Morrowind Patch 1.6.5 [Rebirth].esm
Morrowind Rebirth 4.3 - Racial Diversity 1.7 [Addon].esm
Morrowind Rebirth 4.3.esp
Morrowind Rebirth 4.3 - Balmoras Underworld 1.0 [Addon].esp
Morrowind Rebirth 4.3 - Mercenaries BETA [Addon].esp

These are all activated, after the BSAs and File Paths are all registered. Each mod installed and contained within its own folder, within OpenMW. So I didn't ovewrite anything in Rebirth with Tamriel Rebuilt stuff as their files are in separate folders, within Data Files. 

One thing I did notice in the Readme for the OpenMW Patch for version 03 and 04 was this line:

Unpack the archive file, and add the resultant TD-Compat to your openmw.cfg file AFTER the line where Tamriel Data itself is defined.

I am not sure what this means. I don't know what nor did I see any resulting TD-Compat after installing. It sounds like what it is saying is to add the file path to the openmw.cfg like you must do with all mods added to OpenMW, but I performed that step at the very end of the install, when I added the actual Tamriel Rebuilt mod (that patch is contained on the Data Files page). 

So I am not sure where I went wrong, but I tried to be as detailed as possible with my steps without being redundant. I hope I can get some help with this because no matter what I do, for years, I have been unable to get this one particular mod to work, and I've modded the game quite a bit, so I don't know what I'm overlooking or doing wrong.

Thanks for your time.


Yep, sadly the creator of

Ragox's picture

Yep, sadly the creator of Rebirth doesn't believe that compatibility with Tamriel Rebuilt is an important thing for his mod.
There are also other not so obvious issues like the item renaming and stat changing, which results in big inconsistancies with TR (and the other PT mods). I'm sorry to say, but as it stands you have to decide between the two mods.

If you do decide for using TR you might want to try my More Detailed Places mod in combination for simply improved settlements.

Ah, so this is a

Mr.Anomaly's picture

Ah, so this is a compatibility issue with Rebirth then, and I did install correctly? I did not attempt to run the game with only TR but that is why I mentioned Rebirth, after all. 

Sigh, bummer man. I saw a mod installation video on the tube that explained to me how to install mods in OpenMW and he used Rebirth and TR as examples, implying he has them installed and running. I was extremely excited about this, hoping for that experience. 

Well, thank you for the answer.

The unlinked doors and lack

sirrah's picture

The unlinked doors and lack of NPCs you're encountering are expected behaviour; the western half of the mainland is in TR_Preview, which is the file containing the incomplete portions of the mod. Most of the exteriors in these regions have no interiors linked yet, so the doors won't lead anywhere. Head east to find more complete content, a map showing the division between the two files is here:
The issue with the trees is a bit unclear, I imagine it's the result of Rebirth changing the vanilla meshes in some fashion; do you see similar errors around Seyda Neen? 

The floating barrels/chest are an issue with TR (wrongly) re-using the unique activators elsewhere in the mod. OpenMW can't disable objects with multiple instances, so they end up hanging there after the ship has been successfully disabled. This is a known problem, but I'm not sure if it's actually been reported on the new bugtracker.

Thank you for the reply.

Mr.Anomaly's picture

Thank you for the reply. After reading it I decided to do some testing. (Beware, novel ahead)

I uninstalled Morrowind Rebirth (moved the installation folder out of the OpenMW Data Files folder so I can just put it back later if need be, and deleted the file path from the OpenMW.cfg) and attempted to run Tamriel Rebuilt by itself.

Booted up the game, created a new game, and went through everything until I was free in Seyda Neen again with my super fast Argonian, Tesssssst (yeah I'm a dork). No errors or anything odd that I saw on boot up (I haven't checked any logs though, but it booted and ran fine). Once I was free in Seyda Neen I confirmed that the floating barrels and chest were still there, but I'm happy to know that it is normal and not an issue with my installing it incorrectly. I ran to a nearby dead guy (poor Processus, you greedy dog) to grab 200 septims and took the new boat at the dock to "Rhanim" (lol, I got that wrong before). The doors and such were still funky but as you said, normal. It is in the northwestern area of TR just below that obvious marshland on the map, south of Solstheim. So thanks once more for confirming this to be a normal thing with TR_Preview.esp. I can live with having it active just to run around then, it looks gorgeous even barren as I discovered next.

So, confirming that without Rebirth, the trees were working and looked proper, I started running south/southeast.  Came across Verarchen, which had a bit more going for it so that was cool. I continued further south and came across Kartur, in which were many empty homes and a very lonely Redoran Guard, haha. Anyway again I assume I am in beta area so I continued south and east a bit more, came across Bodrem and at some point took a travel to Baan Malur, and saw some progression the further I got so I felt pretty good about that. I'll check the map to see where the real content starts but I am certainly keeping Preview around. It's just too pretty. And yeah to be clear again, works/looks fine with Rebirth uninstalled.

So I exited, again not saving. I then reinstalled Rebirth, same as before with openmw.cfg yadda yadda (I am only repeating that to drive home that I'm not missing steps, lol, sorry for redundency) and started a new game again, and went forth with Tesssssst Jr. Everything in Rebirth was normal - I love OpenMW install and uninstall man, so clean and easy without messing stuff up by overwriting files. Anyway once free in Seyda Neen and confirming Rebirth was proper again, I re-looted the 200 gold and ran around the marshes for a bit looking at all the trees. They looked perfectly fine around Seyda Neen, so no issues there. I then went to the boat and took it back to Rhanim to check the trees. 

They were borked again. Definitely. So, I opened the console to note the effected trees and saw pretty consistently the following:

Those 6 trees were always the effected ones. And not all of them were affected, just some (maybe like 30% in some spots, less in others). It's a bit hard to describe what they look like but essentially it is two meshes, the trunk and canopy (entire thing basically) of one tree and the branches of another (without its trunk) sharing the same exact spot. If the trunk happens to be skinnier than the one belonging to the branches from the other mesh, you get floating branches - if the trunk happens to be thick it doesn't look bad, aside from different textures lol. It seemed it was always the dead, scraggly trees that sometimes appeared as floating branches, too.

Anyway, confirming which trees seemed to be the issue around Rhanim (there may be more, it could be the whole set of flora_bc_trees - those are just the ones I saw) I walked the same route through Verarchen, Kartur, traveled around to Bodrem and Baan Malur again to check the other trees or for any other oddities, from Parasols to BM trees (pines), and more - and discovered none - pretty much everything else looked perfectly fine. All of the textures provided by Rebirth seem to work as well, so no issues aside from those six flora_be_trees. This isn't difinitive mind you, I only checked the areas near those 5 towns, which were surprisingly diverse - mostly skimming around the perimiter and the walk in between. But in that time this is all I saw.

I wonder if that is easily fixable.

So yeah, firstly, I accidentally put "be" instead of "bc" when I typed the names of those trees. Fixed.

Secondly, I did some more running around and found a few more things I missed, with Rebirth installed. I spent most of the time looking on the outskirts of towns at the trees and such, not much in them, when I looked prior. 

In Verarchen I saw floating lanterns (light_de_paper_lantern_01_200) where I am assuming were meant to be trees with said lanterns hanging on the branches, or something of that nature. Some of the (replaced I believe) WG trees in the area had said lanterns floating near them, so that's why I assumed so - plus there were other lanterns correctly attached to frames sticking into walls/rock (each of which I assume is probably not affected, or affected enough, by Rebirth, to have floating/clipping issues - unlike the trees). I can imagine there are many more issues of this nature that I missed initially. Bummer man.

EDIT 2:::
So I tried removing all of the flora_bc_tree_xx meshes from the Rebirth files, and loading up a new game to see if that helped. It did replace all of the new Rebirth trees with the Vanilla ones (everything else Rebirth related seemed to still be fine too), but when I went to Rhanim I noticed it didn't fix the issue. So I looked at the affected trees again and I think I realized something.

The issue didn't seem to be with the meshes where the whole tree was present, only the floating branches themselves. Meaning no matter what mesh with the trunk and canopy was there, the floating/out of place branches remained. The set of floating branches that I noted belonged to flora_bc_tree_10.

Looking at the original rebirth meshes folder ( f ) I noticed the only bc ones that were actually added were: 
flora_bc_tree_01 - 08 and 12-13. Not included were flora_bc_tree_09, 10 and 11. 10 being one of the set of floating branches I saw.

I know prior I mentioned 03, 06, 07 and 08 as affected trees, but I believe those were each trunks (the whole mesh, rather), with branches from 09, 10 or 11 (the three excluded from Rebirth) sticking out of or floating near them. This might lead to the conclusion that whatever trees Rebirth didn't edit might be affected? At least concerning the bc trees. The wg trees and lanterns thing in Verarchen, is a little different because like I said, I saw a few floating next to what I am fairly sure are trees changed by Rebirth (I'll check again tomorrow, sorry it's getting late) so that just seems to be a conflict. I did see one of the lanterns floating in the middle of one of the entrances to Verarchen (can't remember which, two archway walls between two hills, possibly north since I came from that direction) which is initially why I checked the whole town and noticed the rest. Is there supposed to be a tree there? Or anything else that lantern is meant to be attached to, I guess?

Might be overanalyzing all of this but whatevs, if it helps, it was still kind of fun to see if I can put some stuff together. I'll check more tomorrow and answer some of my own questions, but I'm just throwing my notes out there for anyone interested I guess. I'd give my left family jewel to see these two incredible mods work together (of course in OpenMW - gonna be hard to go back). If I keep updating this for whatever reason I may try to include screenshots as well. Might toss this post onto the Rebirth nexus or something as well.

EDIT 3:::
I popped a link to this thread on Johan's nexus page for Rebirth. He replied already and told me it's all good, he knows what's up, and is currently working on a hotfix already. Sweet! Sorry for the many typos to anyone that read this trainwreck before I got back to it.