"Actor has no animation class" CTD upon entering any TR area

5 posts / 0 new
Last post
Goldenself's picture
Goldenself
Joined:
2016-04-12 00:24
Last seen:
4 years 10 months ago

Hi guys, I’m sorry if this is answered elsewhere as I think it’s likely a problem with my mod set up rather than a bug. The title says it all, I’m also including a screenshot.  The actual actor can vary but this always happens pretty quickly upon entering a TR area. It doesn’t matter if it’s a new game or a loaded save. I’ve only gone to TR areas via flight, if that matters. 

I installed with MGSO 3.0 but upgraded MGE XE to its latest version. I’m also using the .dll from the 0.9,4,1a version of MWSE. This is because the game doesn’t even start when I use the latest 0.9.5-alpha MWSE .dll from the Bethesda forums. I am not opening an external launcher and I did not disable the internal MWSE for MGE XE as it’s already the latest version, and the game, as I said, won’t seem to work with the latest version of MWSE. But I’ve troubleshot the crap out of MWSE and I’m sick of it. I want to see if maybe this is a common issue for TR that can just be easily solved before I go back to it.

I’m also using the Oblivion-like combat tweaks found here, which requires a bashed patch.

 Thanks so much for this amazing work, just hope I can manage to play it at some point.

edited for link and image fixes

 

Goldenself's picture
Goldenself
Joined:
2016-04-12 00:24
Last seen:
4 years 10 months ago

No one has had a problem like this? I’ve tried from a clean install, just installing MGSO, followed by MWSE, followed by TR. I’ve used the two different versions of MWSE I mentioned in all sorts of combinations and permutations of files without this problem going away even once. And as I said, I tried screwing with the versioning of MGE XE as well. I’m really stumped and I desperately want to solve this.

abot's picture
abot
Joined:
2016-01-21 17:58
Last seen:
14 hours 39 min ago

I’m assuming you already verified to have TR_Data.bsa registered in your Morrowind.ini, If not, do it first

Then, verify you have no old vermai-related meshes in
Data Files\Meshes\TR\
folder

[EDIT] then, verify in the Morrowind in game options menu to have AI distance (and maybe also view distance) maximized

 

P.S. forum administrator is there a way to disable the obnoxious javascript editor autosave message covering half words while you type?

Atrayonis's picture
Atrayonis
Lead DeveloperDeveloperInterior DeveloperQuest Developer
Joined:
2015-09-28 20:13
Last seen:
4 hours 31 min ago

abot

P.S. forum administrator is there a way to disable the obnoxious javascript editor autosave message covering half words while you type?

Not without updating the editor. I’m currently testing a newer version on the dev site and plan on putting it on here during the early weekend.
After that – no more autosave (popup).

Goldenself's picture
Goldenself
Joined:
2016-04-12 00:24
Last seen:
4 years 10 months ago

 

Thanks! Somehow I missed the .ini step, sorry for asking a dumb question.