"TR_m1_noga-togroi"->set gotX to ( GetPos, X )
should be e.g.
set gotX to ( "TR_m1_noga-togroi"->GetPos X )
Personally I would change the script like this:
; This script was formerly called TR_m1_q_TO_ACK-20. I have renamed it due to the problems
; that dashes can cause in script names (at least in OpenMW). -- arvisrend, 29 May 2013